[MPlayer-users] playing files from password required ftp sites?

Jason Grindlay aileronnoir at yahoo.com
Mon Jan 31 01:56:30 CET 2005


Does anybody know what I'm doing wrong here?   I can
get the file I'm trying to access manually with a ftp
client but if I try to have mplayer  access it.  I
have the results below.

{68} > mplayer -noframedrop -nosound -v -dumpstream
MPlayer 1.0pre3-RPM-3.2.2 (C) 2000-2003 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Northwood 2186 MHz
(Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1
SSE2: 1
Compiled with Runtime CPU Detection - WARNING - this
is not optimal!
To get best performance, recompile MPlayer with
Reading config file /etc/mplayer/mplayer.conf
Reading config file /usr/home/jasong/.mplayer/config
Reading /usr/home/jasong/.mplayer/codecs.conf: Can't
open '/usr/home/jasong/.mplayer/codecs.conf': No such
file or directory
Reading /etc/mplayer/codecs.conf: 61 audio & 169 video
CommandLine: '-noframedrop' '-nosound' '-v'
get_path('font/font.desc') ->
font: can't open file:
font: can't open file:
Using MMX (with tiny bit MMX2) Optimized
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') ->
Can't open input config file
/usr/home/jasong/.mplayer/input.conf: No such file or
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed: 53
get_path('day36-240x135-mpeg4.mov.conf') ->

Unknown protocol 'ftp'
Unable to open URL:
Resolving ftp.tripod.com for AF_INET...
Connecting to server ftp.tripod.com[]:21
[ftp] < 220 Welcome to Tripod FTP.
[ftp] > USER username
[ftp] < 331 Username set to username. Now enter your
[ftp] > PASS password
[ftp] < 230 User 'username' logged on.
[ftp] > TYPE I
[ftp] < 200 Type set to 'I' (IMAGE aka BINARY).
[ftp] > SIZE day36-240x135-mpeg4.mov
[ftp] < 213 6709839
[ftp] > PASV
[ftp] < 227 Entering Passive Mode
[ftp] > RETR day36-240x135-mpeg4.mov
[ftp] < 150 Opening BINARY mode data connection for
Warning streams need a type !!!!
STREAM: [ftp]
STREAM: Description: File Transfer Protocol
STREAM: Author: Albeu
STREAM: Comment: reuse a bit of code from ftplib
written by Thomas Pfau

And then it just stops and stays there untill I kill
it (I've tried leave it for hours to make sure it
wasn't just being slow), a check with netstat shows
that there is a connection to the ftp site but no data
is being sent/recieved or else sometimes a few bytes
are downloaded and then it stops.   I've tried two
different   ftp sites with videos on them and both had
the same result.  Any ideas?


p.s.  I've also tried with the latest version of 
mplayer and the results were the same.

Do you Yahoo!? 
Take Yahoo! Mail with you! Get it on your mobile phone. 

More information about the MPlayer-users mailing list