[MPlayer-users] playing files from password required ftp sites?

Dominik 'Rathann' Mierzejewski dominik at rangers.eu.org
Mon Jan 31 03:08:23 CET 2005

On Monday, 31 January 2005 at 01:56, Jason Grindlay wrote:
> Hi,
> Does anybody know what I'm doing wrong here?   I can
> get the file I'm trying to access manually with a ftp
> client but if I try to have mplayer  access it.  I
> have the results below.
> {68} > mplayer -noframedrop -nosound -v -dumpstream
> ftp://username:password@ftp.tripod.com/day36-240x135-mpeg4.mov
> MPlayer 1.0pre3-RPM-3.2.2 (C) 2000-2003 MPlayer Team

This is an ancient version of MPlayer. Please upgrade to 1.0pre6.

> And then it just stops and stays there untill I kill
> it (I've tried leave it for hours to make sure it
> wasn't just being slow), a check with netstat shows
> that there is a connection to the ftp site but no data
> is being sent/recieved or else sometimes a few bytes
> are downloaded and then it stops.   I've tried two
> different   ftp sites with videos on them and both had
> the same result.  Any ideas?

I see it's using passive mode. Perhapse the two sites are
unreachable using passive mode and will only work using
PORT command. Have you tried using a regular ftp client
to see which way it is?


MPlayer RPMs maintainer: http://greysector.rangers.eu.org/mplayer/
"I am Grey. I stand between the candle and the star. We are Grey.
 We stand between the darkness ... and the light."
        -- Delenn in Grey Council in Babylon 5:"Babylon Squared"

More information about the MPlayer-users mailing list