[MPlayer-users] Some TV Out problems... NO-SPAM

The Wanderer inverseparadox at comcast.net
Sun Jan 25 06:53:31 CET 2004

Malte Horst Arthur Skoruppa wrote:

> Hi,
> I'm using dev-CVS-031207-15:14-3.3 mplayer on a 2.4.20-4GB-athlon
> Linux system.
> I have a Sapphire ATI Radeon 9500 Pro.
> My TV out works under X, i.e. my X11 drivers support the tv out.
> However, when I run mplayer with xv driver, there is no image in the
> tv screen. The part of the screen where the movie should be displayed
> stays black in the tv (I can see it on the monitor, though).
> I had a look at the documentation and I tried to use the xvidix
> driver, but it says (with -vo xvidix -v):
> No vidix driver name provided, probing available ones (-v option for
> details)!
> vidixlib: PROBING: /usr/local/lib/mplayer/vidix/radeon_vid.so
> [radeon] Can't find chip
> vosub_vidix: Couldn't find working VIDIX driver
> [x11] NET style stay on top (layer 0). Using state
> Error opening/initializing the selected video_out (-vo) device.
> But /usr/local/lib/mplayer/vidix/radeon_vid.so does exist (actually,
> all these 9 *_vid.so files exist in that directory)!

What "Can't find chip" means is not that the file doesn't exist, but
that the program can't find the corresponding hardware needed to
actually use that driver. If the file didn't exist, the program wouldn't
know to look for the hardware.

I can't help you with your problem as a whole, however; I have much the
same difficulty myself, and have never been able to get VIDIX to work.

       The Wanderer

A government exists to serve its citizens, not to control them.

More information about the MPlayer-users mailing list