[MPlayer-users] Mencoder creating AVI without index.

D Richard Felker III dalias at aerifal.cx
Sun Mar 9 17:39:48 CET 2003

On Sun, Mar 09, 2003 at 09:14:15AM -0500, rbtq7ol02 at sneakemail.com wrote:
> [Automatic answer: RTFM (read DOCS, FAQ), also read DOCS/bugreports.html]
> I recorded a file with mencoder, and I can't seek when playing it (mplayer 
> complains of it having no index).  I tried the following to fix:
> mencoder -ovc copy -oac copy -o fixed.avi orig.avi
> but  the new file has the same problem.  Also tried with -idx and -forceidx, 
> and with -oac pcm, with no change.  If reencode with -endpos and cut it (I 
> tried making it 40 minutes), the cut version works, but I need the whole 
> file.  As it is, mplayer can't seek in it and I haven't found any editing 
> tools that can load it.  The file is 2.3GB large, the problem only seems to 
> go away if I make it smaller (the 40min cut was 1.6GB).  I also tried to use 
> avicat to fix it, but avicat won't read it.  Any suggestions, other than 
> finding a place that I can safely split it into two smaller pieces before I 
> do the rest of my editing?

AVI cannot have an index if it's > 2 GB, without (unsupported) opendml


More information about the MPlayer-users mailing list