[MPlayer-users] compiling mplayer with ff's mp3

james james at kirk.math.twsu.edu
Fri Jul 26 08:17:02 CEST 2002

Should be noted: this is on a zaurus (strongarm pda)

I have tried to get libmad to work (problems compiling libmad), and have 
failed so far. 

I am trying to get ffmp3 to work but on both the zaurus and a x86 (k7) it 
comes up with this error:

command line (athlon):

mplayer -ac ffmp3 file.avi

output: (say if you want more, video works just fine)
Can't find codec for audio format 0x50 !
*** Try to upgrade /home/james/.mplayer/codecs.conf from etc/codecs.conf
*** If it's still not OK, then read DOCS/codecs.html!

Is ffmp3 support broken? or is there some magical configure option (didn't 
seem to be and I looked quite carefully.

Additionally: is there some way to disable libmp3? It probably doesn't take 
up much space, but at 2.2mb (out of 32 std) for the zaurus it is simply 
wasted space because of the lack of an fpu.

James L

ps: here is the configure options used by me for on the zaurus compiling of 
./configure --disable-gcc-checking --disable-mencoder 

after commenting out the libpthread test 
(set pthreads to use  -Lpthread or it will not work)

More information about the MPlayer-users mailing list