[MPlayer-dev-eng] [rfc][patch] mplayer-mt, -lavdopts threads=2 and -vo gl failure on mpeg-1 and theora

Uoti Urpala uoti.urpala at pp1.inet.fi
Tue Jan 19 09:47:09 CET 2010

On Tue, 2010-01-19 at 07:28 +0300, Yuriy Kaminskiy wrote:
> Not sure if that belongs here (ffmpeg-mt is not yet complete/stable/supported),
> but anyway.
> History: as my X2 4850e insufficient to display h264/1080p movies, I've tried
> build mplayer with ffmpeg-mt libraries; at first everything worked fine, but
> then I looked at other mt-aware codecs, and stumbled over nasty problem.

I just answered a similar question on the mplayer-users list yesterday.
Try -noslices. I think the slice callback (draw_horiz_band) is the one
triggering problems with threads enabled.

You also seem to be using some kind of svn-based FFmpeg-mt build. All
the ones I've seen have been broken (at least incorrect video vs
subtitle/audio sync). For almost all users the git repo at
git://repo.or.cz/mplayer-build.git is the best way to use thread
support. Based on the output your build seems somewhat unusual though
and could need tweaking to get similar results if you really want those
(they're not just the result of some weird packaging script or such); at
least --enable-gui for the internal GUI is no longer supported.

More information about the MPlayer-dev-eng mailing list