[MPlayer-dev-eng] [rfc][patch] mplayer-mt, -lavdopts threads=2 and -vo gl failure on mpeg-1 and theora

compn tempn at twmi.rr.com
Tue Jan 19 13:36:25 CET 2010

On Tue, 19 Jan 2010 10:47:09 +0200, Uoti Urpala wrote:
>On Tue, 2010-01-19 at 07:28 +0300, Yuriy Kaminskiy wrote:
>> Not sure if that belongs here (ffmpeg-mt is not yet complete/stable/supported),
>> but anyway.
>> History: as my X2 4850e insufficient to display h264/1080p movies, I've tried
>> build mplayer with ffmpeg-mt libraries; at first everything worked fine, but
>> then I looked at other mt-aware codecs, and stumbled over nasty problem.
>I just answered a similar question on the mplayer-users list yesterday.
>Try -noslices. I think the slice callback (draw_horiz_band) is the one
>triggering problems with threads enabled.

his command makes use of noslices already.

>$ mplayer -v -lavdopts threads=2 -demuxer lavf -vfm ffmpeg -dr -noslices \
>-correct-pts -vo gl:yuv=4:rectangle=2:lscale=1:cscale=1:force-pbo \
>MPlayer SVN-r30206+ffmpeg-mt-5eb0c64+local-4.1.2 (C) 2000-2009 MPlayer Team


More information about the MPlayer-dev-eng mailing list