[FFmpeg-devel] [PATCH] avfilter/af_channelsplit: add channels option
Paul B Mahol
onemda at gmail.com
Wed Mar 21 22:24:20 EET 2018
On 3/21/18, Nicolas George <george at nsup.org> wrote:
> Paul B Mahol (2018-03-21):
>> >> + uint64_t channel_layout;
>> >> + int nb_extracted_channels;
>> > Inconsistent variable names.
>> I dont follow.
> The two variables describe the same entity, they should have the same
> base name: nb_extracted_channels and extracted_channels, obviously.
>> Where do you see I copy pasted anything?
> The block I quoted is almost identical to the block just before.
> Duplicated code is unacceptable. Factor it.
It is hardly identical, and I can not read your mind.
And it is functionally incompatible.
Enough bikesheds from you!
>> Accepted stuff fixed locally and gonna apply.
> Send the updated patch for review. But fix the duplicated code before.
> Nicolas George
More information about the ffmpeg-devel