[FFmpeg-devel] [PATCH] avfilter/af_channelsplit: add channels option
george at nsup.org
Wed Mar 21 20:01:03 EET 2018
Paul B Mahol (2018-03-21):
> >> + uint64_t channel_layout;
> >> + int nb_extracted_channels;
> > Inconsistent variable names.
> I dont follow.
The two variables describe the same entity, they should have the same
base name: nb_extracted_channels and extracted_channels, obviously.
> Where do you see I copy pasted anything?
The block I quoted is almost identical to the block just before.
Duplicated code is unacceptable. Factor it.
> Accepted stuff fixed locally and gonna apply.
Send the updated patch for review. But fix the duplicated code before.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 833 bytes
Desc: Digital signature
More information about the ffmpeg-devel