[rtmpdump] Need help with rtmpdump url parser

Adam Malcontenti-Wilson adman.com at gmail.com
Thu Dec 15 01:46:07 CET 2011

I got it to work (in 2.3) by using
but it's a bit of a hack, relying on the current URL parsing isn't the
best idea as it can (and has previously) changed.

However, I do find it interesting that the current parser
automatically adds mp4: to the start of the playpath if it detects a
.mp4 extension (and then removes that .mp4 extension), but does
nothing with regards to f4v. Perhaps an automatic mp4: would be good
for f4v extensions?

On Thu, Dec 15, 2011 at 11:29 AM, Manuel Reimer <manuel.reimer at gmx.de> wrote:
> Hello,
> my problem is the following:
> This command works:
> rtmpdump -r 'rtmp://vod.daserste.de/ardfs' -y
> 'mp4:videoportal/mediathek/Fernsehfilme+im+Ersten/c_200000/209593/format246444.f4v'
> But this one fails:
> rtmpdump -r
> 'rtmp://vod.daserste.de/ardfs/videoportal/mediathek/Fernsehfilme+im+Ersten/c_200000/209593/format246444.f4v'
> I also tried to trick the URL parser to do the right thing like this:
> rtmpdump -r
> 'rtmp://vod.daserste.de/ardfs//videoportal/mediathek/Fernsehfilme+im+Ersten/c_200000/209593/format246444.f4v'
> But the result still doesn't play, as the application name now is "ardfs/"
> and not just "ardfs".
> Is there a trick to get this to play without the more complex command line?
> If not: Is it possible to improve the url parser to work for this URL?
> Thanks in advance
> Yours
> Manuel
> _______________________________________________
> rtmpdump mailing list
> rtmpdump at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/rtmpdump

Adam Malcontenti-Wilson

More information about the rtmpdump mailing list