[rtmpdump] rtmpsuck failure with server response of invalid ttl

Howard Chu hyc at highlandsun.com
Mon Jan 4 05:08:49 CET 2010

loqs wrote:
> Sorry for not responding sooner thanks for looking into this
> unfortunately server is still rejecting connection.  Connect packet
> sent by client and the generated one seem almost identical apart
> from this missing object encoding which is not included because its
> type 0.0 if that was included messages would be same size.  I am
> including a wireshark dump of a failed session in the hope that
> helps.  Please let me know if theres any more debug info I can
> provide.

Try the latest svn. It will still get this same error, the first time, but the 
client will immediately rety and the 2nd attempt should succeed. Wireshark 
shows that the first attempt fails even for the regular Flash client, so it's 
just a bug in their authentication system. (Fancy that, we've found a bug in 
Adobe's code.)

The results are not reliable, it took me a couple of tries to get a valid 
session but eventually it works.

More information about the rtmpdump mailing list