[MPlayer-users] VO: Description: Null video output

The Wanderer wanderer at fastmail.fm
Fri Mar 25 13:24:07 EET 2022

On 2022-03-24 at 19:26, Craig Jameson wrote:

> I am attempting to install mplayer in a user account.  The audio works.
> But, no window opens to play video.  This is the same for mp4 files and
> webm files.
> The system is running RHEL 8.5.
> I believe the following is the salient part of the verbose output:


> using /dev/fb0
> Can't open /dev/fb0: Permission denied
> [fbdev2] Using device /dev/fb0
> [fbdev2] Can't open /dev/fb0: Permission denied

This seems to indicate an attempt to use -vo fbdev2 (which, if memory
serves me correctly, only works when playing from the console - i.e.,
not in a graphical environment such as X)...

> VO: [v4l2] No such file or directory

...and this seems to indicate an attempt to use -vo v4l2...

> vo_cvidix: No vidix driver name provided, probing available ones (-v
> option for details)!
> [vidixlib] PROBING: cyberblade
> [cyberblade] Error occurred during pci scan: Operation not permitted


> [vidixlib] No suitable driver can be found.

...but this appears to indicate an attempt to use -vo cvidix.

Did the command line used specify any -vo option?

If not, did/does the appropriate config file (see the man page, search
for '/config') specify any -vo option?

What VO options are compiled in and available? You should be able to
find this out by running:

$ mplayer -vo help

If no VO was specified, either on the command line or in the config
file(s), then presumably MPlayer will have been running through its
compiled-in VO options in search of one that can work. If that's
correct (it's been a very, very long time since the last time I tried
that scenario), then the fact that it apparently tried those three
options and gave up might seem to indicate that those are the *only*
three VO options compiled in to this instance of MPlayer.

That seems odd and unlikely, but it might explain the problem; that
would be an exceedingly restricted set of VO options to be limited to.

> Running lspci in a user's account returns, among many other lines, this
> one:
> 01:00.0 VGA compatible controller: NVIDIA Corporation GP107 [GeForce
> GTX 1050 Ti] (rev a1)
> Setting permissions of fb0 to allow all users to read it has been
> tried.  It has no effect.

I'm not clear on whether fb0 is usable outside of the console, either.
It's possible that it is, but my learned intuition about the way these
things work would not lead me to expect it to be.

(I parse "cvidix" as "console VIDIX", by contrast to "xvidix" as "X
Window System VIDIX".)

> So, mplayer returns that pci scans are not permitted, when they are. 
> And, mplayer sets the video driver to null, when there is a driver for
> my video card.

Note that there is a difference between "video driver" and "VIDIX
driver". Just because you have the former, that doesn't necessarily mean
you have the latter.

> This same machine was running RHEL 7.5.  mplayer ran just fine on it
> when installed in the same user account.  From apperances, this new
> install of mplayer is running just fine.  It is just that the video
> does not play.

Do you remember what VO was reported as being used, under the previous

Is there any difference regarding how MPlayer was installed, between
these two setups?

What version of MPlayer is this, and what version was that? (This
information should be reported at the start of the MPlayer terminal
output; that's one part of the reasons why it's typically requested to
provide the *full*, un-snipped, output when reporting a problem.)

   The Wanderer

The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all
progress depends on the unreasonable man.         -- George Bernard Shaw

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20220325/da40be6f/attachment.sig>

More information about the MPlayer-users mailing list