[MPlayer-users] OSD menu rendering crashes after r38142

max muster steyding at yahoo.de
Sun May 31 15:57:26 EEST 2020

 Hello Reimar,
maybe my fault - i've not blank CONFIG file so my last post maybe obsolete :-(
After blank CONFIG file it seems that mplayer now crashes only with the following options since r38187:
1) -osdlevel 3 only
2) -menu-startup -osdlevel 3
3) -menu-startup -osdlevel 3 -nosound
If i use option -menu with different options it works now :-)
>From my side everything is ok from now.
Thanks for your efforts.

Attached gdb log with option -nosound (with works now)

    Am Samstag, 30. Mai 2020, 19:23:07 MESZ hat Reimar Döffinger <reimar.doeffinger at gmx.de> Folgendes geschrieben:  
 On 30 May 2020 19:04:21 CEST, max muster <steyding-at-yahoo.de at ffmpeg.org> wrote:
> strange.
>I've compiled mplayer r38142 with ffmpeg 4.2.2 source (because of MF
>encoder issues in newer ffmpeg release) and i used current ffmpeg
>source as i compile mplayer with current release.
>mplayer r38142 still worksmplayer r38188 still not working.
>This bug appears since mplayer source code was change with "new/other"
>SSE cpu flags (?) (r38143)
>So i guess it is not ffmpeg related.

It looks to me like the big your seeing now is not the one you saw first.
But to confirm, could you test that you don't have a crash without - menu-startup?
And make a backtrace using -nosound and maybe compiling with --enable-debug. 
One thing I noticed now is that you have a 32 bit build, that I have not tested yet.

MPlayer-users mailing list
MPlayer-users at mplayerhq.hu
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mplayer-nosound.zip
Type: application/x-zip-compressed
Size: 13487 bytes
Desc: not available
URL: <https://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20200531/b3d2cd17/attachment.bin>

More information about the MPlayer-users mailing list