[MPlayer-users] Encoding with libx264

Alexander Strasser eclipse7 at gmx.net
Sun Nov 5 15:59:24 EET 2017


On 2017-10-18 18:18 +0200, bugzzzz wrote:
> I tried a lot of options with mencoder and H.264 codec (libx264 from lavc and x264enc) and nothing works.
> It seems that mencoder does not support H.264 codec any more as runtime messages display "broken ffmpeg default settings detected" and propose options not supported by mencoder. So the mencoder man pages are outdated !
> So, could you confirm that mencoder does not support encoding with H.264 codec family ?
> Thank you.

It's important to not mix up option names between ve lavc and ve x264.

This is your original command changed to ve x264 (-ovc x264 and -x264encopts):

  mencoder //home/azor/tmp/t1c1 -nosound -ovc x264 -x264encopts bitrate=1000:subq=5:8x8dct:frameref=2:bframes=3:b_pyramid=normal:weight_b:pass=1 -vf pp=,scale=-1 -o /dev/null

I didn't check if those encoding settings make sense. Also I don't know
if you really need and want to do multi-pass encoding.

BTW there is still an mencoder ML which might spawn better answers to
your mencoder questions:

    -> MEncoder-users: general support mailing list for MEncoder-related questions.

Best regards,

> Le lundi 16 octobre 2017 23:15:23 bugzzzz a écrit :
> > Hello,
> > 
> > I am new to this mailing list.
> > And as there is no forum or other place to look for issues already posted, here is my problem :
> > 
> > I have just compiled mplayer-checkout-2017-10-17 to test libx264 codec.
> > http://www.mplayerhq.hu/DOCS/HTML/en/MPlayer.html#menc-feat-x264 recommend for example the following options for high quality encoding :
> > subq=5:8x8dct:frameref=2:bframes=3:b_pyramid=normal:weight_b
> > 
> > But when I run the 1st pass encoding process, I get the following result :
> > /usr/local/mplayer-checkout-2017-10-17/bin/mencoder //home/azor/tmp/t1c1  -nosound -ovc lavc -lavcopts vcodec=libx264:vbitrate=1000:subq=5:8x8dct:frameref=2:bframes=3:b_pyramid=normal:weight_b:turbo:vpass=1 -vf pp=,scale=-1 -o /dev/null
> > 
> > MEncoder UNKNOWN-4.9.2 (C) 2000-2017 MPlayer Team
> > Option lavcopts: Unknown suboption 8x8dct
> > Error parsing option on the command line: -lavcopts
> > 
> > Exiting... (error parsing command line)
> > 
> > It seems that "8x8dct" option is not recognized by mencoder whereas it is documented in http://www.mplayerhq.hu and mplayer/mencoder man pages.
> > 
> > Could you tell me more about this option ?
> > 
> > Thanks a lot.

More information about the MPlayer-users mailing list