[MPlayer-users] osdlevel regression/bug/bad behaviours

Sebastien WILLEMIJNS sebastien at willemijns.com
Sun Feb 15 22:59:01 CET 2015


I have windows version r37368 compiled by

first kind of bug:
With an old version (begin or mid-2014) of MPLAYER, i saw
reminded/elapsed time of an audio file, now i only see an % not more
(see the last line of my screentext shot below, how to do that ?

d:\>d:\mplayer\mplayer.exe blahblah.wma -osdlevel 3 -osd-duration 1000
MPlayer sherpya-r37368+g52f2adc-4.9.2 (C) 2000-2015 MPlayer Team
203 audio & 423 video codecs

Playing d:\blahblah.wma.
libavformat version 56.19.100 (internal)
ASF file format detected.
[asfheader] Audio stream found, -aid 1
Clip info:
 title: Track 2
Load subtitles in d:\
Load subtitles in d:/sub/
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 56.21.102 (internal)
AUDIO: 44100 Hz, 2 ch, floatle, 128.0 kbit/4.54% (ratio: 16002->352800)
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
AO: [dsound] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Position: 6 %


second kind of bug with 2 illogic behaviours: 
- i tried "mplayer.exe d:\blahblah.wma -osdlevel 3 -osd-duration 1000"
with an audio file, the % was displayed 1s as expected, osd-dfuration
with 100 or 10000 give good behaviour, of course as explained above only
see %
- i tried "mplayer.exe d:\blahblah.mp4 -osdlevel 3 -osd-duration 1000"
with a video file, osdlevel 3 gives the whole time elapsed/remained time
+ % 
but osd-duration parameter is not used during this time...

please check these 3 behaviours ;)

More information about the MPlayer-users mailing list