[MPlayer-users] Trouble playing UDP multicast stream in mplayer

Prabashwara Seneviratne prabash.s at outlook.com
Sun Dec 7 04:25:05 CET 2014

Thanks for all the input guys. I don’t think there is anything wrong with the stream since the set top box (which is Linux based (http://www.utstar.co.jp/files/1526.pdf)) plays the stream perfectly, so it must be something wrong with the configuration. 

@reimar I’ll try what you said  and I’ll also mess with the other kernel parameters to see whether it’ll help

@andy The stream is from a wired lan (the stream comes over ADSL to a specific port on the router) I have tried udpxy but the conditions were not ideal (on a Linux VM). I’ll try again

Thanks again

Sent from Windows Mail

From: Andy Furniss
Sent: ‎Saturday‎, ‎December‎ ‎6‎, ‎2014 ‎8‎:‎22‎ ‎PM
To: mplayer-users at mplayerhq.hu

Reimar Döffinger wrote:
> On Tue, Dec 02, 2014 at 06:22:55PM +0600, Prabashwara Seneviratne
> wrote:
>> Thanks for the reply @reimar I followed your suggestions and
>> installed the latest svn mplayer and updated my distro (xubuntu
>> 14.04) for good measure. It also worth mentioning that i moved to
>> a faster machine as well (Core 2 Duo 2.8ghz, 2GB DDR2, Nvidia GTS
>> 450)
> Hm, too bad that there's no easy way for me to test myself.
>> I tried using the ffmpeg://udp:// command instead and it resulted
>> in this
>> bash at Bash-C2D:~/peo$ mplayer ffmpeg://udp://
> Maybe something like
> ffmpeg://udp://
>  would be better...
>> using the same command that i used before, with a bigger cache
>> (mplayer --cache 8192 udp:// the playback was
>> slightly better(i.e not as many artifacts), but still not perfect
>> (perhaps due to the faster machine)
> Just to exclude issues I'd start with something crazy like -cache
> 100000 Unfortunately right now I don't have many more ideas...

Maybe packet loss on lan.

If using wireless don't! or maybe try udpxy, but that would need control
over a box with a good connection.

If wired then test - it doesn't take much loss to mess up a udp tv stream.

Admittedly testing against a little modem box may not work, but you
should be able to get zero loss with something like (as root)

ping -s 1400 -f -c 10000 .......

If you get some loss it's time to start un/re plugging trying/cleaning
different ports etc.

MPlayer-users mailing list
MPlayer-users at mplayerhq.hu

More information about the MPlayer-users mailing list