[MPlayer-users] dvdnav not playing titles that worked

Alexander Roalter alex at roalter.it
Thu Nov 17 00:36:55 CET 2011

On 11/16/2011 11:19 PM, Roger Pack wrote:
>>> Is this still a problem?
>>> If yes, could you try it with this
>>> http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2011-November/001561.html
>>> and https://gist.github.com/1358679 applied and see what happens?
>>> -roger-
>> The problem is still there, even with the patch applied (but I don't see
>> what would be in the githup, it's only text).
> Save it as a diff, then apply it.
I could swear there was a different text when I looked at it before. Now 
it's clear, it's the call to the new function. But the result is still 
the same -> I reckon it's something with the virtual machine that 
doesn't get interpreted/executed correctly.

It fixes my seeking problems with some Paramount copy protected DVDs 
(Transformers 2 and Star Trek XI comes to mind). There is still some 
cell switching mayhem that happens tho, and I see the following messages:

A: 834.3 V: 834.3 A-V:  0.002 ct: -0.110 320/320 11%  0%  2.3% 7 0
libdvdnav: get_PGCN failed. Was trying to find pgcN in domain 28 0
libdvdnav: chapter NOT FOUND!
libdvdnav: get_PGCN failed. Was trying to find pgcN in domain 2
libdvdnav: chapter NOT FOUND!

[ac3 @ 0xf627a0]incomplete frame
A: 855.2 V:   0.0 A-V:855.202 ct: -0.104   0/  0 ??% ??% ??,?% 8 0
[ac3 @ 0xf627a0]frame sync error
A: 892.8 V: 892.7 A-V:  0.052 ct:  0.208  77/ 77 129%  1% 23.5% 8 0

> Maybe ping the libdvdnav dev's?
> Another idea is, since it worked once, to try to bisect it to find the
> offending commit (ex: try different versions of libdvdnav, etc.)

I will see when I get the time for it...


More information about the MPlayer-users mailing list