[MPlayer-users] dvdnav not playing titles that worked

Roger Pack rogerdpack2 at gmail.com
Wed Nov 16 23:19:48 CET 2011

>> Is this still a problem?
>> If yes, could you try it with this
>> http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2011-November/001561.html
>> and https://gist.github.com/1358679 applied and see what happens?
>> -roger-
> The problem is still there, even with the patch applied (but I don't see
> what would be in the githup, it's only text).

Save it as a diff, then apply it.

> I get the audio from the main
> feature (The Columbia logo fanfare), but a bit of video from a different
> title on the disc. After that, I get the columbia logo, and audio/video sync
> slowly catches up.

> To finish things up, I get the following output:
> *** libdvdread: CHECK_VALUE failed in libdvdread4/ifo_read.c:843 ***
> *** for cell_playback[i].first_sector <=
> cell_playback[i].last_vobu_start_sector ***
> *** Zero check failed in libdvdread4/ifo_read.c:864
>    for cell_position[i].zero_1 = 0x04

Maybe ping the libdvdnav dev's?
Another idea is, since it worked once, to try to bisect it to find the
offending commit (ex: try different versions of libdvdnav, etc.)

More information about the MPlayer-users mailing list