[MPlayer-users] Fw: Subversion revision 32895 has errors on Fedora 14 x86_64

stan RegBur_Flydan8 at q.com
Sun Feb 13 05:48:12 CET 2011

I used the wrong address on my reply so it didn't make it to the list.
Here it is forwarded.

On Sat, 12 Feb 2011 23:42:44 +0000 (UTC)
Carl Eugen Hoyos <cehoyos at ag.or.at> wrote:

> stan <RegBur_Flydan8 <at> q.com> writes:
> > I recently started having compile errors on the updates from
> > subversion.
> > 
> > Whether I run ./configure or ./configure --enable-gui, I get the
> > following messages immediately after I start it.
> I definitely don't know why it fails for you (it works for me) and I
> have already been wrong once today, but could you confirm that you
> already tried: rm -Rf ffmpeg
> ./configure
> ?
> (For unknown reasons, FFmpeg had to switch to git, and configure will
> pull a working copy for you after you removed the - old - svn
> version.)

As you said, that pulled in the ffmpeg.  And configure then worked
fine.  I thought it might be some sort of reconfiguration, so I had
earlier deleted the entire mplayer svn directory, and repulled trunk
from the web using subversion. It contained the faulty ffmpeg version
and didn't ask if it could get the web version.  Now that we've had this
conversation, anyone who pull the subversion repository for mplayer
will know to delete the ffmpeg directory before they configure and

Everything compiled, but when creating the mplayer executable,
there was an error:
/usr/bin/ld: cannot open output file mplayer: Is a
collect2: ld returned 1 exit
make: *** [mplayer] Error 1 

For some reason it nested the source structure, creating the original
mplayer directory within the checked out mplayer directory, and thus
preventing the executable from being built.

Thanks for your help.  I'll play around with it until I get it working,
now that I know that it is the ffmpeg directory causing the original

More information about the MPlayer-users mailing list