[MPlayer-users] latest SVN wedges in tight loop with -vo xvmc

Norman Ramsey nr at eecs.harvard.edu
Wed Jul 2 01:06:57 CEST 2008

 > > In getting ready for football season, I've tried to bring software
 > > up to date.  Bad idea!  The ancient mplayer I was using with the
 > > NVIDIA 1.0-7676 drivers worked, but the latest SVN mplayer wedges
 > > at launch.  strace shows it in a tight loop calling sched_yield()
 > > as quickly as possible.  Kill produces an error message, but it
 > > continues to soak up 99% of CPU until killed with kill -9.
 > >
 > > I'm using the NVIDIA XvMC library from the latest Linux drivers, i.e.,
 > > NVIDIA-Linux-x86-173.14.09.  I've attached a zip file contining the
 > > output of mplayer -v and also the configure.log from the build.
 > The log shows that your card is NV17 model.
 > I own the same and I know that the latest version that
 > works with it is 96.43.05.

I see.  So it sounds as if I should go back to the nvidia web site,
get the nvidia 96.43.05 drivers (and library), recompile mplayer, and
things should work OK?  Thank you for this very helpful information!

 > You actually don't say that you are using 173.14 drivers,
 > you say that you are using the library from 173.14...

Indeed I did not say, but I am in fact using both the kernel module, X
driver, and library all from 173.14.

 > Taking parts from one driver and putting it in another
 > would surely lead to problems.

Inded so!

 > Next time read bugreports.html what is needed for debugging.

Ah, thank you --- I missed this at the end of the README file.


More information about the MPlayer-users mailing list