[MPlayer-users] Dump DTS stream of DVD failed while playable

Nico Sabbi Nicola.Sabbi at poste.it
Thu Feb 21 12:30:51 CET 2008

On Thursday 21 February 2008 12:25:09 SBBG wrote:
> > upload a sample to incoming, please
> Oh, yep, I guess it's a good idea.
> But the file is huge, I guess I have to crop a part of it.
> But this cause another problem...
> I tried to crop the file in this way:
> mplayer B3-vol.1.vob -endpos 20s -aid 137 -dumpstream
> But it stuck at:
> Playing B3-vol.1.vob
> And show no progress.
> But I can play it quite normally( dts decoding start at 10sec by
> libdca ) if I pull out the dumpstream flag.
> Then I tried mencoder to pass through both video & audio stream
> like: mencoder B3-vol.1.vob -oac copy -ovc copy -endpos 20s -aid
> 137 -o B3-cropped.vob
> But it produce a file with no audio.
> Next I tried mencoder to rip the audio stream only by:
> mencoder B3-vol.1.vob -oac copy -ovc copy -endpos 20s -aid 137 -o
> B3-cropped.rawaudio -of rawaudio
> But unfortunately, it failed again. An empty output file is left.
> May I just upload the whole file? Or do you have any good
> suggestion for me to crop the file?

dd if=file.vob of=file.out bs=1024 count=N

where N must be big enough to include the dts track and small enough
to make the file small

More information about the MPlayer-users mailing list