[MPlayer-users] Dump DTS stream of DVD failed while playable

SBBG sbbgnew at gmail.com
Thu Feb 21 12:25:09 CET 2008

> upload a sample to incoming, please

Oh, yep, I guess it's a good idea. 
But the file is huge, I guess I have to crop a part of it.
But this cause another problem...

I tried to crop the file in this way: 
mplayer B3-vol.1.vob -endpos 20s -aid 137 -dumpstream

But it stuck at:
Playing B3-vol.1.vob
And show no progress. 

But I can play it quite normally( dts decoding start at 10sec by libdca )
 if I pull out the dumpstream flag. 

Then I tried mencoder to pass through both video & audio stream like:
mencoder B3-vol.1.vob -oac copy -ovc copy -endpos 20s -aid 137 -o 
But it produce a file with no audio. 

Next I tried mencoder to rip the audio stream only by:
mencoder B3-vol.1.vob -oac copy -ovc copy -endpos 20s -aid 137 -o 
B3-cropped.rawaudio -of rawaudio
But unfortunately, it failed again. An empty output file is left.

May I just upload the whole file? Or do you have any good suggestion
for me to crop the file?

More information about the MPlayer-users mailing list