[MPlayer-users] Strange MPlayer behavior when playing on TV

Dominik 'Rathann' Mierzejewski dominik at rangers.eu.org
Sat Feb 16 15:50:52 CET 2008

On Saturday, 16 February 2008 at 14:19, Marcin Zajączkowski wrote:
> Hi,
> MPlayer works strange with X-server (only) started on TV. It shows the 
> first frame (or some from the begin of movie) and stops. When 
> paused/resumed it plays a few frames and stops again. The same when 
> forwarded.
> I happens on Fedora 8. I have no problem with it on Fedora 5. I use the 
> same config for nvidia tv-out in Xorg and the same script to play 
> mplayer. I have even tried start it from xterm started on TV - the same.
> It have tried many different video drivers (standard, xv, sdl, gl, even 
> caca!). All the same. It works normal on my monitor, but not on my TV.
> Suspending Xorg problem I have checked Totem and VLC and they work fine.
> I use mplayer 1.0-rc2 (RPM 1.0-0.90.rc2 by Dominik Mierzejewski from 
> livna.org), X Window System Version 1.3.0 (xorg-x11-server 
> and legacy nvidia binary driver (packaged by livna) - 
> xorg-x11-drv-nvidia-legacy-71.86.01-4.lvn8.1 (I have GeForce 2 Ti 
> graphic card).
> I don't know if it's a problem with mplayer, but maybe you know what 
> could be a reason (and maybe in addition how it could be fixed)?

It might have been fixed later in SVN. Please download the latest source
snapshot, build it and test if it still misbehaves. Assuming it works with
current SVN, if you could then identify the SVN commit that fixed the
issue, I could apply it to the RPM package. I would do it myself, but
because I have no TV, I can't test it.


MPlayer developer and RPMs maintainer: http://mplayerhq.hu http://rpm.livna.org
There should be a science of discontent. People need hard times and
oppression to develop psychic muscles.
	-- from "Collected Sayings of Muad'Dib" by the Princess Irulan

More information about the MPlayer-users mailing list