[MPlayer-users] MPlayer playing video really fast

aeiiyoup aeiiyoup at gmail.com
Sun Feb 3 13:48:22 CET 2008


I've discovered a problem which I've had with MPlayer for a long time. 
Basically the video plays really fast to the end. I've tried the workarounds 
The bug I am experiencing isn't on there.

The distribution I am using is Gentoo Linux. I've had the problem with MPlayer 
1.0_rc1_p20070824, 1.0_rc2_p24929-r1, 1.0_rc2_p24929-r2 and 
1.0_rc2_p24929-r3. (-r represents a gentoo patch either to the ebuild or a 

I even tried the latest snapshot from the MPlayer SVN repo as of Sun Feb  3 
05:52:25 UTC 2008. (Latest change was 2008-02-02T17:22:07.871112Z) and bug 
still occurs.

I'm using kernel 2.6.24 gentoo-sources (it's a vanilla kernel basically with a 
few minor patches http://dev.gentoo.org/~dsd/genpatches )

I have a Intel(R) Pentium(R) M processor 1.86GHz GenuineIntel GNU/Linux
I'm using the latest stable version of glibc in portage, which is 2.6.1. 
Upstream latest stable version is 2.7 (havn't tried that) and binutils 2.18
I'm using Xorg 7.3 and xorg-server

This is my default gcc information.

# gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
with: /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/4.1.2 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/g++-v4 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --enable-libmudflap --disable-libssp --disable-libgcj --with-arch=i686 --enable-languages=c,c++,fortran --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 4.1.2 (Gentoo 4.1.2 p1.0.1)

I've got a Intel Corporation Mobile 915GM/GMS/910GML Express Graphics 
Controller in this machine and am using the 
Also tried the stable versions. Ie 2.2.0.

The videos that cause MPlayer this grief can be found at: (Note it's softcore 

Length: 2,639,444 (2.5M) http://andi-pink.com/videos/ironingteaser.avi
Length: 2,816,342 (2.7M) http://andi-pink.com/videos/milkteaser.avi	
Length: 2,823,600 (2.7M) http://andi-pink.com/videos/popcornteaser.avi
Length: 2,679,662 (2.6M) http://andi-pink.com/videos/orangeteaser.avi

Also I've tried codeine which is a frontend to xine-lib. This plays 
the videos fine. Also VLC 0.8.6d does as well.

If you have any other questions ask them here and I'll try as best as I can to 


More information about the MPlayer-users mailing list