[MPlayer-users] DVD playback?

mikkel meinike mimeini at gmail.com
Tue Apr 29 11:42:41 CEST 2008


I'll really like to be able to see DVD film with mplays on my box, but
so hasn't yet been a success for me. my last attempt however have
given me some hope of a solution. Mplayer were in a position to tell
me all sorts of information
about the medium but not display it.
This mplayer that I am talking about I copied from an older laptop
where I compiled it some time a go.
My original intention was to compile mplayer for my new box but the
compilation failed much to my surprise since it compiled so fine on
the same gnu/Linux system (vector Linux 4) on an other box earlier.  I
think it must be the hardware that gives the compilation problems. I
can maybe explain the compilation problems in a later post if that is
Ok I than copied the binary mplayer from my laptop to the new box and
it worked right away playing my mpeg and flv files. So I wanted to try
playing DVD I tried different commands that I looked up with google an
the one that seems to work the best was when I first mounted the DVD
drive (when I play CD with xmms I should not mount the CD drive first)
and than execute the following command:

mplayer dvd://1-17 -dvd-device /mnt/dvd

I maneged to log the output from mplayer and that follows here. Maybe
some of you are able to analyse this and give me some advise what to
do. What ever it is compile a new mplayer or it can be done with some
config etc. with this functioning mplayer.

MPlayer 1.0rc1-2.95.3 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (Family: 15, Model: 2, Stepping: 7)
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

Playing dvd://1.

etc. etc. etc...

Playing dvd://16.

Playing dvd://17.
There are 17 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.
number of audio channels on disk: 0.
subtitle ( sid ): 0 language: unknown
number of subtitles on disk: 1
MPEG-PS file format detected.
MPEG: No audio stream found -> no sound.
VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  9000.0 kbps (1125.0 kbyte/s)
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [x11] 720x576 => 768x576 Planar YV12
V:   0.0   1/  1 ??% ??% ??,?% 0 0  [J
V:   0.0   1/  1 ??% ??% ??,?% 0 0  [J

Exiting... (End of file)

More information about the MPlayer-users mailing list