[MPlayer-users] ASS subtitles in an MKV aren't synced or timed correctly

Steven Littiebrant / Groxx imgroxx at gmail.com
Mon Jun 19 00:36:34 CEST 2006

I'm not sure if this is a new bug, as I haven't tried it on the pre7
release, but on pre8 my ASS subtitles have been bugging out.  I'm
using a Mac, and haven't tested the release on any of my Linux
They've been displaying, but they start out slightly behind where they
should be.  In a short time, they show up too early.  The whole time,
they're displaying much shorter than any other player shows them.
Oddly enough, after this initial sync-change, they stay appearing
ahead of when they should by about the same amount.  As in, they jump
forward a good two seconds in the first minute, and then they stay a
second or so too fast for the rest of the file.

To make it worse, neither the '-subdelay <sec>' nor the x/z subtitle
delay options have ANY effect on when they appear, at any point.

I've tried the same files on other players, both on my Mac and on my
PCs, and the subtitles display perfectly, so evidently this is an
MPlayer issue.  Are there any other commands I should try, and/or is
there any way I can help to find out what this bug is?
I'll add another message when I've tried the pre7 release, but that
won't be for at least a few hours.

More information about the MPlayer-users mailing list