[MPlayer-users] Bug 1 of 2: MKV fast forward doesn't work correctly - Mac OS X 10.3.9

Ergzay ergzay at everyoneproductions.com
Sat Apr 15 10:02:17 CEST 2006

On 2006/04/15, at 2:20, Ergzay wrote:
> On 2006/04/14, at 16:08, Ivan Kowalenko wrote:
>> On Apr 14, 2006, at 01.55, Ergzay wrote:
>>> On 2006/04/14, at 2:09, Alexander Strange wrote:
>>>> On Apr 14, 2006, at 2:02 AM, Guillaume POIRIER wrote:
>>>>>> Like I said it happens with ALL and ANY mkv files.
>>>>> All of them work just fine on my machine (debian-based x86-64), and
>>>>> they have always been. Seeking is fast and accurate. No problem
>>>>> whatsoever.
>>>>> The problem _may_ be with Mac OS X, but if it's the case, you're 
>>>>> all
>>>>> alone: few ppl on the core team have that setup thus, it's hard for
>>>>> them to reproduce the problem and fix it.
>>>>> Guillaume
>>>> I'm pretty sure this problem occured on all platforms when the 
>>>> audio delay patch was added, but Corey fixed the bug shortly 
>>>> afterwards and seeking started working again in mkv for me, on OS 
>>>> X.
>>>> Maybe you should make sure you're completely up to date and 
>>>> distclean/re-configure/build from scratch?
>>> Well I just a few hours ago built mplayer from CVS so the problem is 
>>> current. A few weeks ago I did a completely clean compile and 
>>> installation on my desktop dual 2.5GHz G5 and that exhibits the same 
>>> problem.
>> I'm running MPlayer CVS from Feb 01 2006, and my only problem is the 
>> inability to rewind MKV files. I'm running OS X (10.4.6) on a G4 
>> (1.07 GHz). You know, this might not be a problem with MPlayer. I've 
>> noticed that certain video outs can cause odd problems. For example: 
>> cropdetect doesn't work with Core Video, but runs fine with Quartz. 
>> What VO are you using?
> Well I use the one titled macosx. It's the default if your computer 
> supports it. This may be specific to the OS as well. I am running 
> 10.3.9. I have no problem rewinding mkv (its usually how I get to 
> where I want to fast forward to, fast forward then rewind by normal 
> steps to the place) but when I try to fast forward it does an 
> exponential increase in fast forward amount the closer I am to the end 
> of the video. So if I am half way through a half hour video and hit 
> the over arrow once (which is set as default to go forward 10 seconds) 
> it once it will sometimes jump to the end and close the video or 
> almost to the end. If I fast forward at the beginning it goes forward 
> about 15-20 seconds instead of 10, a much smaller amount.

I forgot to add that there is no change when I use quartz instead. I 
also tried SDL (SDL chose quartz to use) and still no change.


More information about the MPlayer-users mailing list