[MPlayer-users] GCC 4 and above

Vladimir Mosgalin mosgalin at VM10124.spb.edu
Sat Apr 1 13:40:50 CEST 2006

Hi Drewe Zanki!

 On 2006.04.01 at 21:15:07 +1000, Drewe Zanki wrote next:

> Trying to compile Mplayer. I run Fedora Core 4 (with no Gui - I just use SSH
> for comand line and webmin for some stuff - it is a pure server), which has
> GCC 4.something installed. I get a bunch of errors about depreciated
> commands and options, etc.

Here is the catch: the last stable release doesn't support gcc 4.
1.0pre7try2 can be compiled with it, but the resulting mplayer will be
crash in swscaler, possibly in some other parts. So try out cvs version.

IF you are already trying to compile cvs, then mention it! In that case,
it's a bug, there should be no problems with compiling cvs with current
stable gcc (4.1 or 4.0.2, or something like that.. not sure).

> I realise I had to disable GCC checking in the compile.
> I tried the pre-compiled RPM's but the Mencoder one does not include Xvid
> support - which is the whole point of this excercise!
> I have no idea how to downgrade my GCC. I checked and FC4 I think came with
> V4 of GCC - I need to go to the FC3 version? I tried Yum and it didn't have
> anything. I can't use a Fedora package cause it complains I don't have Core
> 3.

Actually, no problems with that. Just install compat-gcc-32 and
compat-gcc-32-c++ packages and use CC=gcc32 (CXX=g++32 for C++ programs)
to use the gcc 3 compiler. But in mplayer case, better just update to
cvs version.

Btw, do you have latest updates installed? Most FC versions are quite
buggy at the time of the release and get polished only by the time the
next version is out. Which means, right now FC4 + all updates is the
best FC version out there.



More information about the MPlayer-users mailing list