[MPlayer-users] tdfxfb

Vit Pelcak spearhead at seznam.cz
Thu Sep 29 11:54:05 CEST 2005

I'm currently running Debian Sid with own kernel 2.6.13 with archck5 patch. I have last version of mplayer. My PC is K-6 II a 3dfx Voodoo 3 2000 PCI. I use resolution max. 1024x768-16 because of hardware. I have compiled kernel with: 


So, I have compiled support of 3dfx framebuffer and mtrr compiled in kernel. 

I have compiled mplayer with these parameters:

--enable-tdfxfb --enable-tdfxvid
I can't still compile tdfx_vid.o (because of lots of parse errors I'm not likely to solve, btw if someone managed to compile tdfx_vid.o for 2.6.13 kernel, I will strongly appreciate if you'll send it to my e-mail address spearhead at seznam.cz), so I'm trying tdfxfb. When I run 

mplayer -vo tdfxfb some_movie 

I get this message: 

tdfxfb: Couldn't map memory areas: Invalid argument
Error opening/initializing the selected video_out (-vo) device.

I don't have device tdfxfb in /dev folder and don't know how to make it. 


Boot video device is 0000:00:0b.0
[drm] Initialized tdfx 1.0.0 20010216 on minor 0: 3Dfx Interactive, Inc. Voodoo 3
fb: 3Dfx Voodoo3 memory = 16384K
Console: switching to colour frame buffer device 128x48
vga16fb: initializing
vga16fb: mapped to 0xc00a0000
fb1: VGA16 VGA frame buffer device

I have framebuffer runiing console running at 1024x768-16 at 100Hz by tdfxfb. I run kernel with parameter: video=tdfxfb:1024x768-16 at 100. So framebuffer should be working. 

I'm quite new in Linux and I'm getting desperate as I can't find sollution in forums elsewhere.

Thank you very much.

More information about the MPlayer-users mailing list