[MPlayer-users] Re: No picture when playing VSoft's H.264 demo clips

adland123 adland123 at yahoo.com
Tue May 3 16:15:07 CEST 2005

Haakon Riiser <haakon.riiser <at> fys.uio.no> writes:

> Just tried some of the demo clips available at
> <http://www.vsofts.com/h264/videoclips.html
> and none of them
> produced a picture, just a black display.  Should it have worked?
> (I'm using mplayer 1.0pre7 and my binary codec package is
> essential-20050412.tar.bz2.)

It was broken for me as well.

solution was the following

boot into windows
download samples
install their free decoder package (beta) has no time limit mentioned
open sample clip in GSpot application to read info about the required dll
reboot to linux
mount windows partition and copy the vsshdsd.dll into the win32 codec dir
delete old vssh codecs which were using vfw not dshow
plus there was three of them required instead of one
vssh264.dll vssh264core.dll,vssh264dec.dll 

edit  in mplayer build dir etc/codecs.conf
make mplayer

test samples (all types seemed to playback) 

--- main/etc/codecs.conf        2005-04-25 03:26:14.000000000 -0400
+++ updated/etc/codecs.conf     2005-05-03 10:06:53.000000000 -0400
@@ -1610,9 +1610,10 @@
   info "VSS H.264"
   status working
   fourcc VSSH
-  driver vfw
-  dll "vssh264.dll" ; need also vssh264core.dll, vssh264dec.dll
-  out BGR24 flip
+  driver dshow
+  dll "vsshdsd.dll"
+ guid 0x6931C7e7, 0x75b7, 0x4729, 0xa1, 0x53, 0xa8, 0xad, 0x99, 0xbd, 0xf7, 0x0b
+  out YV12

 videocodec vsswlt
   info "VSS Wavelet Video Codec"

More information about the MPlayer-users mailing list