[MPlayer-users] Mplayer doesn't compile

Tor Olav Stava t-ol-sta at online.no
Sat Aug 27 11:25:26 CEST 2005

Reimar Döffinger wrote:

>On Fri, Aug 26, 2005 at 01:00:54AM -0700, RC wrote:
>>On Fri, 26 Aug 2005 09:49:29 +0200
>>Tor Olav Stava <t-ol-sta at online.no> wrote:
>>>Maybe not the cause of the roubles, but I discovered during my LFS/
>>>BLFS build that installing the drivers from NVidia will brake the
>>>build of MPlayer. Reason is that NVidia replaces a few GL header
>The headers in the 7667 package have cause no trouble so far, though I
>have deleted the headers from Mesa first (the ones in
>/usr/X11R6/include, the nVidia ones go into /usr/inlcude it seems).
Seems I have to apologize for my ignorance.. :( Tried to replace the 
original header files from the Xorg installation with the headers from 
NVidia and recompiled MPlayer, no errors.. If I remember correctly, I 
used an older version of the drivers when it failed. Now using the 7667 
version, so seems it works now.

The Nvidia headers (on my system, at least) installs into 
/usr/include/GL which is a symbolic link to /usr/X11R6/include/GL.

I just assumed that the new drivers would still break the build, and 
included the --disable-gl option without further testing.. Well, so much 
for my (useful) information :)

C ya all

Tor Olav

More information about the MPlayer-users mailing list