[MPlayer-users] Encoding, reencoding and alsa

Bradley Alexander storm at tux.org
Sat Aug 20 00:56:57 CEST 2005

I'm having issues with encoding video, apparently since the change to the DivX 
codec within mplayer. I preface my questions by stating that I tried to RTFM, 
but TFM is MIA on the mplayer website. I wanted to see if the docs were 
updated to address the changes in the codec and how to deal with it. So I 
searched the mailing list and finally resorted to google, but none of the 
suggestions have worked thus far.

In any case, I am using mplayer through webvcrplus to record video from 
television. The command line I am using is

 mencoder tv://#STATION# -tv 
-ovc lavc -lavcopts vcodec=#FFMPEGCODEC#:vbitrate=#VBITRATE# -oac mp3lame 
-lameopts cbr:vol=6:br=#ABITRATE# -vf pp=lb -endpos #TIME# -o "#OUTPUT#"

where #FFMPEGCODEC# is DivX5.0, #VBITRATE# is 800 and #ABITRATE# is 128.

After recording, I pull the commercials with avidemux, then re-encode to 
usable size (~350MB/hour). The command I use to re-encode is a script using a 
two-pass method. My command line is 

mencoder ${infile} -o ${outfile}  -oac copy -ovc lavc -lavcopts 
-vf scale=640:480 -sws 2 -vop pp=fd

I have tried both -ffourcc DX50 and -srate 48000, which are steps I found 
either on the mailing list or linked from google. 

And since the change of codec, some of my mplayer installations (Marillat's 
mplayer-1.0-pre7-0.0 deb) give me the following error:

Cannot find codec matching selected -vo and video format 0x34504D46.
Read DOCS/HTML/en/codecs.html!
AO: [oss] 44100Hz 2ch s16le (2 bps)
Building audio filter chain for 44100Hz/1ch/s16le -> 
Video: no video

The machines which "work" (Marillat's mplayer-1.0-pre7cvs20050716-0.0 deb) 
still give me 

alsa-space: xrun of at least 0.061 msecs. resetting stream?,?% 0 0 82%          
alsa-space: xrun of at least 0.071 msecs. resetting stream1.8% 3 0 77%          
alsa-space: xrun of at least 0.067 msecs. resetting stream1.5% 4 0 73%          

and the video is very choppy. Since I cannot access the manual, can someone 
help me to get this working? Things that were recorded long ago (late last 
year) perform fine, its just stuff recorded in the last several months, since 
the changes to the codec.

Any advice would be much appreciated.

Bradley M. Alexander                       |
IA Analyst, SysAdmin, Security Engineer    |   storm [at] tux.org
Debian/GNU Linux Developer                 |   storm [at] debian.org
Key fingerprints:
DSA 0x54434E65: 37F6 BCA6 621D 920C E02E  E3C8 73B2 C019 5443 4E65
RSA 0xC3BCBA91: 3F 0E 26 C1 90 14 AD 0A  C8 9C F0 93 75 A0 01 34
You only have the rights you are willing to fight for.

More information about the MPlayer-users mailing list