[MPlayer-users] Indeo codecs and x86_64

Dominik 'Rathann' Mierzejewski dominik at rangers.eu.org
Tue Apr 26 15:48:37 CEST 2005

On Tuesday, 26 April 2005 at 13:46, Tony Bloomfield wrote:
> Hi, tried a bit of archive searching but didn't find anything on this subject.
> I've built pre7 on an AMD64 system (Suse 9.2), and installed all-codecs. Most 
> video clips play okay, but not Indeo 4.1 or 5.0, which play sound only. The 
> error message I'm seeing is from dlopen(), to the effect that vid_iv41.xa (or 
> iv 50 equiv)  doesn't exist. Well, the file does exist, I have permissions 
> and the directory is in my library path, and was specified in --with-animdirs 
> in the configure step.
> From similar problems with other apps, I've come to the conclusion that dlopen 
> only ever produces this one output message, regardless of what sort of 
> problem it encounters. I think the problem here is caused by trying to load a 
> 32-bit shared object file from a 64-bit app.

You are correct.

> I tried the addon codecs from the Linuxsoft site which are alleged to be for 
> x86_64 platform, but they produce the same effect. Also, installing source 
> rpms does no good, since the .xa files are still pre-built, presumably on a 
> 32-bit system.
> So can anyone tell me where I might find either a 64-bit version of these .xa 
> files, or instructions to build them on such a system?

There are two options:
- get 64bit Indeo codecs
- use 32bit MPlayer


MPlayer RPMs maintainer: http://rpm.greysector.net/mplayer/
"I am Grey. I stand between the candle and the star. We are Grey.
 We stand between the darkness ... and the light."
        -- Delenn in Grey Council in Babylon 5:"Babylon Squared"

More information about the MPlayer-users mailing list