[MPlayer-users] Indeo codecs and x86_64

Tony Bloomfield tonyb.lx at btinternet.com
Tue Apr 26 13:46:36 CEST 2005

Hi, tried a bit of archive searching but didn't find anything on this subject.

I've built pre7 on an AMD64 system (Suse 9.2), and installed all-codecs. Most 
video clips play okay, but not Indeo 4.1 or 5.0, which play sound only. The 
error message I'm seeing is from dlopen(), to the effect that vid_iv41.xa (or 
iv 50 equiv)  doesn't exist. Well, the file does exist, I have permissions 
and the directory is in my library path, and was specified in --with-animdirs 
in the configure step.

From similar problems with other apps, I've come to the conclusion that dlopen 
only ever produces this one output message, regardless of what sort of 
problem it encounters. I think the problem here is caused by trying to load a 
32-bit shared object file from a 64-bit app.

I tried the addon codecs from the Linuxsoft site which are alleged to be for 
x86_64 platform, but they produce the same effect. Also, installing source 
rpms does no good, since the .xa files are still pre-built, presumably on a 
32-bit system.

So can anyone tell me where I might find either a 64-bit version of these .xa 
files, or instructions to build them on such a system?


More information about the MPlayer-users mailing list