[MPlayer-users] starting video player at precise location in video file

Heitzso heitzso at growthmodels.com
Mon Apr 18 04:00:47 CEST 2005

I posted the question to both transcode and mplayer
list re how to get mplayer/gmplayer (or any player for that
matter) to position accurately in a mpg2 file using -ss. 
For some reason, g/mplayer does this quite fine if you encode
with the transcode dvtodvd.sh script that is posted on their site. 
I don't have the time to sort out why my transcode/mplayer combo
instead did the traditional overshoot, while the transcode
dvtodvd.sh script that does mostly the same encoding works great.

In case someone else wants to sort it out, my transcode/mplex
combo that does not -ss accurately (with matrix.txt taken from
transcode site):
  transcode  -i x.dv -o x  -x dv,dv -y mpeg2enc,mp2enc   \
        -N 0x50 -b 224  --export_prof dvd-ntsc \
        -w 7500 --export_asr 2 --encode_fields b -j 0,8,0,8 \
        -F '8,-c -q 6 -4 2 -2 1 -K file=matrix.txt -R 2'
  mplex -v 0 -V -f 8 -o x.m2v x.mpa -o x.mpg

Anyway, I'm mentioning because it is common to see the remark
that mplayer does not correctly work with -ss, but the truth is more
that mplayer only handles some file formats correctly with -ss.

Other experiments I ran were ...

With mplayer and ogg-vorbis-theora mplayer does not do -ss

Ogg-vorbis-theora libraries do not appear to be optimized
as well as common mpeg2 libraries, and CPU usage for a high
quality compression seemed to be about 3 times higher than
for equivalent quality mpeg2 file.  Net effect was my gentoo/athlon 2200+
with 1.5G of RAM could not play back an ogg-vorbis-theora compressed
video of a marching band, hand held, etc. (so lots of jitter).  Same jittery
video compressed mpeg2 displayed fine on my box with vlc, xine, mplayer
with slightly fatter (larger file, higher quality) compression.

Helix Player may be a lot of folks' favorite little open source player,
but Helix Player could not play back my high quality
test DV file (see above) without essentially freezing up for most of
the video.

I tried taking a mpeg2 file that mplayer had trouble with accurate
seeking into with -ss and turned it into a DVD iso image, then tried
playing the DVD iso with mplayer.  That did not help.  It was a good
experiment, the theory being perhaps the additional info provided by
a full DVD iso image might help mplayer accurately track into the file. 
But, no.  Still highly inaccurate -ss seeking in that case.

But for all of the above problems I encountered, I want to stress
that g/mplayer can accurately -ss into a VBR mpeg2 file if the
VBR mpeg2 file is built the right way (and refer to the dvtodvd.sh
script on the transcode site for clues re what might be the right

I want to thank everyone who pitched in with suggestions.


More information about the MPlayer-users mailing list