[MPlayer-users] No audio encoder (-oac) selected

Larry llwyble at cox.net
Sun Apr 17 23:47:24 CEST 2005

Rich Felker wrote:
> On Sun, Apr 17, 2005 at 03:26:01PM -0500, Larry wrote:
>>I have upgraded MPlayer 1.0pre6-3.3.4
>>Now when I try to record tv programs I get the following error;
>>No audio encoder (-oac) selected
>>I do have an aoudio encoder selected. I read the manpage and did
>>mencoder -oac mp3lame on the command line and I still get the error.
>>Here is the command line I used which has worked for a long time but
>>not with the upgraded edition. Can someone tell me what's up?
>>BTW, the way the TV works fine just running it on mplayer.
>>time=$(date +%d_%m_%Y)
>>/usr/local/bin/mencoder tv://14 -tv driver=v4l:width=320:height=240: \
>>forceaudio:forcechan=2:norm=ntsc:chanlist=us-cable -oac mp3lame -ovc \
>>lavc -endpos 01:00:00 -o show.$time
> is this your literal command, including spaces and backslashes? if so,
> there's your problem. there's a space in the suboptions to -tv, so
> "forceaudio:forcechan=2:norm=ntsc:chanlist=us-cable" is treated as a
> second filename to encode, and the -oac option doesn't get applied to
> the first file (although it should be a global option..?)
> in any case please be sure you've given us the exact command line
> you're using. i expect there's something silly going wrong.
> rich
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> http://mplayerhq.hu/mailman/listinfo/mplayer-users
That was it!

I made the command on a single line without breaking the line with \
and it works now. Sorry for the bother. Also I feel like an idiot. :)

More information about the MPlayer-users mailing list