[MPlayer-users] liba52 trouble

Thomas Dettbarn dettus at dettus.net
Wed Sep 29 13:16:38 CEST 2004


i am writing you because i have some difficulties compiling mplayer
on my computer. i have already tried version 0.93 and now 1.0pre5,
but it is not working.

i have a dual pentium 4 with 2.8 ghz, running redhat 8.0, gcc-version
is 3.2.

when i try to run ./configure it complains about mmx-libraries, so 
i tried to run ./configure --disable-mmx --disable-mmx2, but now it
keeps bitching about 3dnow in the liba52 directory. so i looked up 
the code, and i found something like

#ifdef ARCH_X86
#define HAVE_3DNOW 1
in imdct.h,  which is HORRIBLE! and when i tried to compile mplayer
with ./configure --disable-mmx --disable-mmx2 --disable-3dnow --disable-3dnowex
--disable-liba52 it still insists on using the a52 library. is there 
any way i can fix this? oh, and btw... i am not root on this machine.

     ________________________  __ ____
    /   / __/__  __/__  __/ / / //  _/
   / / / _/   / /    / / / /_/ /_\ \
  /___/___/  /_/    /_/ /_____/____/    Geek and proud of it

More information about the MPlayer-users mailing list