[MPlayer-users] alsa-1.0.6 and hwac3 don't work well

Dominique Dumont domi.dumont at free.fr
Mon Sep 27 18:35:24 CEST 2004

Thomas Lindroth <tholi945 at student.liu.se> writes:

> I have alsa compiled into my kernel. I just upgraded alsa-headers alsa-lib
> alsa-utils alsa-oss alsa-tools to version 1.0.6 from 1.0.5 and hwac3 did
> not work. It say something about a missing file /dev/snd/hwC0D2 or
> something. I downgraded and later tried the 2.6.9-rc2 kernel with alsa
> 1.0.6 in it. I did not get any sound with this. I again tried to upgrade
> all alsa packages to 1.0.6 to get the same version of all my alsa stuff. I
> can play hwac3 now but my amplifier switch between ac3 and stereo rapidly.
> Are there some fix?

A similar question was asked 4 days ago. Here's Peter Zubaj's answers:

You are probaly using alsa-lib > 1.0.4 and in your kernel is alsa 1.0.4
In file /usr/share/alsa/conf/cards/EMU10K1.conf
there are lines in definition for EMU10K1.pcm.iec958.0:

slave.pcm {
		type hw
		card $CARD
		device 2

change device 2 to device 3

If you upgrade your kernel to 2.6.9-rc2 or higher put back device 2

Peter Zubaj

More information about the MPlayer-users mailing list