[MPlayer-users] RealMedia - what RealAudio formats work?

Tony Robinson tony at tonyRobinson.com
Tue Sep 14 15:42:19 CEST 2004

I've spent days and days bashing around trying everything to get
RealAudio to stream in mplayer.

I've tried MPlayer-1.0pre5 and the recent releases MPlayer-20040908
MPlayer-20040910, with and without the recent liveMedia live.2004.09.08
and live.2004.09.09.

I've unpacked all-20040809.tar into /usr/local/lib/codecs/all-20040809
and for good measure I have the latest RealPlayer codecs as well (in

All of these get detected when I run ./configure:

./configure --with-win32libdir=/usr/lib/win32 --enable-live --with-livelibdir=/home/echidna0/ajr/liveMedia/live --with-codecsdir=/usr/local/lib/codecs/all-20040809 --with-reallibdir=/usr/local/Linux/RealPlayer10GOLD/codecs
Checking for Win32 codec DLL support ... yes (using /usr/local/lib/codecs/all-20040809)
Checking for Win32 loader support ... yes
Checking for DirectShow ... yes
Checking for XAnim DLL ... yes (using /usr/local/lib/codecs/all-20040809)
Checking for RealPlayer DLL ... yes (using /usr/local/Linux/RealPlayer10GOLD/codecs)
Checking for LIVE.COM Streaming Media libraries ... yes (using /home/echidna0/ajr/liveMedia/live)

Looks good - yes?

However, on test audio that has been mentioned here before I get:

compute ajr: ./mplayer 'rtsp://rmv8.bbc.net.uk/news/olmedia/cta/progs/rn/rn_v7.rm'
MPlayer dev-CVS-040910-05:00-3.3.4 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium III Katmai/Pentium III Xeon Tanner 563.7 MHz (Family: 6, Stepping: 3)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/echidna0/ajr/.mplayer/config
Reading /home/echidna0/ajr/.mplayer/codecs.conf: 74 audio & 180 video codecs
font: can't open file: /home/echidna0/ajr/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Failed to open /dev/rtc: Permission denied (it should be readable by the user.)
Using nanosleep() timing
Input config file /home/echidna0/ajr/.mplayer/input.conf parsed: 53 binds

Playing rtsp://rmv8.bbc.net.uk/news/olmedia/cta/progs/rn/rn_v7.rm.
Resolving rmv8.bbc.net.uk for AF_INET...
Connecting to server rmv8.bbc.net.uk[]:554 ...
rtsp_session: Not a Real server. Server type is 'unknown'.
Not a Realmedia rtsp url. Trying standard rtsp protocol.
Connected to server: rmv8.bbc.net.uk
Stream not seekable!
Failed to initiate "audio/X-PN-REALAUDIO" RTP subsession: RTP payload format unknown or not supported

MPlayer interrupted by signal 11 in module: demux_open
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

I've also tried Debian packages and RPMs with no luck.

The other test audio mentioned here is rtsp://mm4.rai.it/raitre/blob/ultimo/blob.rm

Does mplayer work on these streams and if so can anyone spot what I'm
doing wrong?

Tony Robinson

More information about the MPlayer-users mailing list