[MPlayer-users] SAA7134, OSS devices

varial at gmx.de varial at gmx.de
Thu Jan 29 04:30:39 CET 2004


MPlayer is great, but I have a tiny problem regarding my TV Tuner Card and
sound output. It is a saa7134 based tv card, using OSS devices (/dev/dsp1,
/dev/mixer1) for sound. What do I have to put on the command line to (g)mplayer
in order to make it read sound input from dsp1? I have tried -tv
adevice:/dev/dsp1:[more stuff], which didn´t work out as expected. I tried some other
options too, and V4L2 detects stereo sound mode, but then I get "Audio: no
sound" when playback starts. Any ideas?

MPlayer output:

Playing tv://.
TV detected! ;-)
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski at zpr.uni-koeln.de>
 comment: first try, more to come ;-)
Selected device: KNC One TV-Station RDS / Typhoo
 Tuner cap: STEREO LANG1 LANG2
 Tuner rxs: MONO STEREO
 Capabilites:  video capture  video overlay  VBI capture device  tuner 
read/write  streaming
 supported norms: 0 = PAL; 1 = NTSC; 2 = SECAM; 3 = PAL-M; 4 = PAL-Nc;
 inputs: 0 = Television; 1 = S-Video; 2 = Composite1;
 Current input: 0
 Current format: BGR24
v4l2: current audio mode is : STEREO
Selected channel: 25 (freq: 503,250)
Forced video codec: rawi420
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred csp: Planar I420)
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 640x480 => 640x480 Planar I420 
Selected video codec: [rawi420] vfm:raw (RAW I420)
Audio: no sound
Starting playback...

I´d appreciate any sort of hint.


+++ GMX - die erste Adresse für Mail, Message, More +++
Bis 31.1.: TopMail + Digicam für nur 29 EUR http://www.gmx.net/topmail

More information about the MPlayer-users mailing list