[MPlayer-users] Garbled audio with RTSP and RealAudio

Stephen Stocker lpar at par1.net
Mon Jan 5 03:10:07 CET 2004

  Hmm. Anybody have the feeling that NASA's streams are screwed up?
  They've got about a million different servers streaming all or part of
  their original streams, and I can't get any of them to work. Maybe
  some flaky rtsp variation? 

  The only difference between what you're describing and my problem is
  that eventually the whole stream quits, with the "BUG!" message
  appearing at some point, usually preceded by a breakup of the video.


>I'm trying to watch NASA TV with the command:
>mplayer 'rtsp://rmbcast.nasa-us2e.speedera.net/alias_ashburn1_btn_2/encoder/rmb
>The picture comes in perfect, but the audio is garbled and completely
>unintelligible.  I've tried this with the CVS version of mplayer (from
>20040104 with ffmpeg 20040104 also) and with the mplayer 1.0pre3 release;
>same results.
>I've also tried with all four combinations of the windows/linux and rp8/rp9
>sipro codecs.  Both Linux codecs produce garbled sound, the windows rp9
>codec produces no sound at all, and the windows rp8 codec crashes mplayer.
>The above stream runs fine when using the realplay binary on the same
>system (but that program is so bad it's painful to use).
>My machine is a Fedora Core 1 box running a linux 2.6.0 kernel.  I'm using
>the OSS emulation in mplayer.  (Audio card is a ensonic 1371).  Mplayer
>plays a wide selection of other video/audio files without problem.

More information about the MPlayer-users mailing list