[MPlayer-users] Garbled audio with RTSP and RealAudio Sipro

Kevin O'Connor kevin at koconnor.net
Sun Jan 4 22:05:45 CET 2004

I'm trying to watch NASA TV with the command:

mplayer 'rtsp://rmbcast.nasa-us2e.speedera.net/alias_ashburn1_btn_2/encoder/rmbcast.nasa-us2e/rmbcast_nasa-us2e_dec312003_0922_52626.rm'

The picture comes in perfect, but the audio is garbled and completely
unintelligible.  I've tried this with the CVS version of mplayer (from
20040104 with ffmpeg 20040104 also) and with the mplayer 1.0pre3 release;
same results.

I've also tried with all four combinations of the windows/linux and rp8/rp9
sipro codecs.  Both Linux codecs produce garbled sound, the windows rp9
codec produces no sound at all, and the windows rp8 codec crashes mplayer.

The above stream runs fine when using the realplay binary on the same
system (but that program is so bad it's painful to use).

My machine is a Fedora Core 1 box running a linux 2.6.0 kernel.  I'm using
the OSS emulation in mplayer.  (Audio card is a ensonic 1371).  Mplayer
plays a wide selection of other video/audio files without problem.


The following is output from mplayer with linux rp9 codec:

MPlayer dev-CVS-040104-12:06-3.3.2 (C) 2000-2003 MPlayer Team

CPU: Intel Celeron A Mendocino/Pentium II Dixon 368.0 MHz (Family: 6, Stepping: 5)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

Reading config file /home/kevin/install/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/kevin/.mplayer/config
Reading /home/kevin/.mplayer/codecs.conf: Can't open '/home/kevin/.mplayer/codecs.conf': No such file or directory
Reading /home/kevin/install/etc/mplayer/codecs.conf: Can't open '/home/kevin/install/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine: '-v' 'rtsp://rmbcast.nasa-us2e.speedera.net/alias_ashburn1_btn_2/encoder/rmbcast.nasa-us2e/rmbcast_nasa-us2e_dec312003_0922_52626.rm' '-vo' 'null'
get_path('font/font.desc') -> '/home/kevin/.mplayer/font/font.desc'
Font /home/kevin/.mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX Optimized OnScreenDisplay
Failed to open /dev/rtc: Device or resource busy (mplayer should be setuid root or /dev/rtc should be readable by the user.)
Using usleep() timing
get_path('input.conf') -> '/home/kevin/.mplayer/input.conf'
Parsing input config file /home/kevin/.mplayer/input.conf
Input config file /home/kevin/.mplayer/input.conf parsed: 52 binds
get_path('rmbcast_nasa-us2e_dec312003_0922_52626.rm.conf') -> '/home/kevin/.mplayer/rmbcast_nasa-us2e_dec312003_0922_52626.rm.conf'

Playing rtsp://rmbcast.nasa-us2e.speedera.net/alias_ashburn1_btn_2/encoder/rmbcast.nasa-us2e/rmbcast_nasa-us2e_dec312003_0922_52626.rm.
Resolving rmbcast.nasa-us2e.speedera.net for AF_INET...
Connecting to server rmbcast.nasa-us2e.speedera.net[]:554 ...
Cache size set to 640 KBytes
Connected to server: rmbcast.nasa-us2e.speedera.net
CACHE_PRE_INIT: 0 [0] 0  pre:0  eof:0  

Cache fill:  0.00% (0 bytes)    

REAL file format detected.
real: File version: 0
Chunk: PROP (504f5250) (size: 0x32, offset: 0x12)
First index chunk offset: 0x0
First data chunk offset: 0x189
Flags (9): [save allowed] 
Chunk: CONT (544e4f43) (size: 0x1a, offset: 0x44)
Chunk: MDPR (5250444d) (size: 0xab, offset: 0x5e)
Found new stream (id: 0)
skip_str: 12 bytes skipped
skip_str: 35 bytes skipped
==> Found audio stream: 0
Found audio stream!
version: 5
frame_size: 320
sub_packet_size: 20
samplerate: 16000, channels: 1
======= WAVE Format =======
Format Tag: 26995 (0x6973)
Channels: 1
Samplerate: 16000
avg byte/sec: 16000
Block align: 320
bits/sample: 16
cbSize: 10
Unknown extra header dump: [14] [0] [6] [0] [3] [0] [40] [1] [0] [0] 
### skipping 0 bytes of codec info
Chunk: MDPR (5250444d) (size: 0x76, offset: 0x109)
Found new stream (id: 1)
skip_str: 12 bytes skipped
skip_str: 20 bytes skipped
==> Found video stream: 1
video fourcc: RV30 (30335652)
H.263 ID: 30203002
unknown id: 30203002
### skipping 4 bytes of codec info
Chunk: DATA (41544144) (size: 0x0, offset: 0x17f)
demux_real: invalid chunksize! (0)
Packets in file: 0
Auto-selected RM video ID = 1
Auto-selected RM audio ID = 0
VIDEO:  RV30 [30203002,010B1030]  320x240  (aspect 0.00)  15.00 fps
[V] filefmt:11  fourcc:0x30335652  size:320x240  fps:15.00  ftime:=0.0667
Clip info:
 copyright: (C) 2002
get_path('sub/') -> '/home/kevin/.mplayer/sub/'
get_path('default.sub') -> '/home/kevin/.mplayer/default.sub'
Opening audio decoder: [realaud] RealAudio decoder
opening shared obj '/home/kevin/install/w32codec/sipr.so.6.0'
Audio codec: [3] 16 Kbps Voice
Audio bitrate: 16.000 kbit/s (2000 bps)  
dec_audio: Allocating 1920 bytes for input buffer.
dec_audio: Allocating 128000 + 65536 = 193536 bytes for output buffer.
AUDIO: 16000 Hz, 1 ch, 16 bit (0x10), ratio: 2000->32000 (16.0 kbit)
Selected audio codec: [rasipr] afm:realaud (RealAudio Sipro)
Opening video decoder: [realvid] RealVideo decoder
realvideo codec id: 0x30203002  sub-id: 0x010B1030
opening shared obj '/home/kevin/install/w32codec/drv3.so.6.0'
INFO: RealVideo codec init OK!
Selected video codec: [rv30] vfm:realvid (Linux RealPlayer 8 RV30 decoder)
Checking audio filter chain for 16000Hz/1ch/16bit -> 16000Hz/2ch/16bit...
[libaf] Adding filter dummy 
[dummy] Was reinitialized, rate=16000Hz, nch = 1, format = 0x00000001 and bps = 2
AF_pre: af format: 2 bps, 1 ch, 16000 hz, little endian signed int 
AF_pre: 16000Hz 1ch Signed 16-bit (Little-Endian)
ao2: 16000 Hz  2 chans  Signed 16-bit (Little-Endian)
audio_setup: using '/dev/dsp' dsp device
audio_setup: sample format: Signed 16-bit (Little-Endian) (requested: Signed 16-bit (Little-Endian))
audio_setup: using 2 channels (requested: 2)
audio_setup: using 16000 Hz samplerate (requested: 16000)
audio_setup: frags:   5/5  (4096 bytes/frag)  free:  20480
AO: [oss] 16000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 16000Hz/1ch/16bit -> 16000Hz/2ch/16bit...
[dummy] Was reinitialized, rate=16000Hz, nch = 1, format = 0x00000001 and bps = 2
[libaf] Adding filter channels 
[channels] Changing number of channels to 2
[dummy] Was reinitialized, rate=16000Hz, nch = 1, format = 0x00000001 and bps = 2
Starting playback...
[libaf] Reallocating memory in module channels, old len = 0, new len = 20478
VDec: vo config request - 320 x 240 (preferred csp: Planar I420)
Trying filter chain: vo
VDec: using Planar I420 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (320x240->320x240,flags=0,'MPlayer',0x30323449)
VO: [null] 320x240 => 320x240 Planar I420 
VO: Description: Null video output
VO: Author: Aaron Holtzman <aholtzma at ess.engr.uvic.ca>
*** [vo] Allocating mp_image_t, 320x240x12bpp YUV planar, 115200 bytes
A:-490750.2 V:   0.0 A-V:-490750.158 ct:  0.000    1/  1   0%  0%  0.0% 0 0 19%

[libaf] Removing filter dummy 
[libaf] Removing filter channels 
uninit audio: realaud
uninit video: realvid
DEMUXER: freeing demuxer at 0x85e7190  
DEMUXER: freeing sh_audio at 0x85e6d88  
DEMUXER: freeing sh_video at 0x85e6e30  
vo: x11 uninit called but X11 not inited..

Exiting... (Quit)

More information about the MPlayer-users mailing list