[MPlayer-users] libmp3lame problem / not solved by FAQ

Mary Strimel mstrimel at comcast.net
Tue Apr 20 21:34:32 CEST 2004

trying to compile mplayer with mp3 encoding support. As suggested by
other posts, i have checked that the various libmp3lame libraries are
located in /usr/lib and I copied them to /usr/local/lib for good
measure.  As suggested in earlier posts, I added /usr/lib to
/etc/ld.so.conf and re-ran ldconfig, and verified that lame.h was in my
/usr/local/include; I also tried running ./configure with
--with-extraincdir=/usr/local/include.   No matter what I do, the
configuration log reports:

> #include <lame/lame.h>
> int main(void) { lame_version_t lv; (void) lame_init(); get_lame_version_numerical(&lv);  printf("%d%d\n",lv.major,lv.minor); return 0; }
> gcc -I/usr/local/include   /root/tmp/mplayer-conf-5061-20198.c -o /root/tmp/mplayer-conf-8220-20198.o -lmp3lame -lvorbis -logg -lm
> /usr/bin/ld: skipping incompatible /usr/lib/libmp3lame.so when searching for -lmp3lame
> /usr/bin/ld: cannot find -lmp3lame
> collect2: ld returned 1 exit status
> ldd /root/tmp/mplayer-conf-8220-20198.o
> ldd: /root/tmp/mplayer-conf-8220-20198.o: No such file or directory
> Result is: no

I am running mandrake 9.2 for AMD64, and installed libmp3lame and -devel from some mandrake rpms I found on Sourceforge.net . . . 
Help! :)

More information about the MPlayer-users mailing list