[MPlayer-users] MPlayer doesn't skip frames

armin.gerritsen at philips.com armin.gerritsen at philips.com
Thu Mar 20 11:28:05 CET 2003


I've ported mplayer to an embeded ARM system using a framebuffer-device. It
plays fine, but I have the problem that when playing AVI (XviD) files with
both video and audio present the video get's delayed a lot. When the
audio-part is then finished, the video will continue playing untill all
frames are played.. Of course the result is that the video takes too long
and is completely out of sync.

 When we disable the sound (-nosound) the video plays fine.

Of course our embeded CPU is very slow, so we can never play normal
DivX-files. However we decreased the size to very small sizes (132x176) so
that our ARM should be able to handle it.

 I also removed the normal MP3-decoder (which uses a FPU, which doesn't
exist on ARM), and tried both the integer-only ffmp3 and compiled and linked
libmad in. The latter seems to be the fastest of the two (the other produces
hickups). We also tried normal PCM-audio, but to no avail.

I tried options like -bps, -nobps, -autosync 30, -framedrop
and -hardframedrop. The result stays the same: mplayer doesn't trough away
enough video frames and also continues playback after the audio-part has

The latter I consider a bug, even if the first would be caused by the fact
that it is our embeded CPU that is simply too slow, even
with -hardframedrop.

So my questions:

- did anyone try mplayer on embeded system?
- is there some -realyhardframedrop, or other option. :-)
- did anyone else notice the 'bug' (unless someone can tell me why it isn't
a bug).

Again, it plays fine without the video (or just sound alone). Note also that
if I take MPEG content the -framedrop option does work, and all stays
perfectly in sync.


Armin Gerritsen

More information about the MPlayer-users mailing list