[MPlayer-users] Can't find any good output driver for Radeon QL (8500LE)

Vladimir Mosgalin mosgalin at VM10124.spb.edu
Fri Feb 7 03:11:51 CET 2003

Hi everybody.

I upgraded my system, now I use ATI Radeon 8500LE (QL) as video card.
XFree86 version is 4.2.0. I played with drivers and mplayer output for
some time and results were unfortunate :(

The detailed descriptions follows, you can see resume in the end of

At first, I tried "radeon" driver from XFree86 (or from gatos project).
Everything was great.  XVideo worked excellent, xvinfo showed lot of
attributes and image formats. mplayer -vo xv worked great too, with
hardware equalizers, however there were no separate RGB correction. -vop
pp worked too.

Then I tried -vo xvidix. Everything was similar to -vo xv, however when
I tried -vop pp, something bad happened. Every time I tried any
postprocess filter, mplayer slowed down about 100 times - I have no
guess how can this be, but that's it.
mplayer -vo dga worked fine, but that wasn't enough, of course.

And there was no hardware opengl support :( mplayer -vo gl/gl2 were slow
as hell.

Then I tried drivers from ATI (fglr200-glc22-4.2.0-1.4.3.i586.rpm).
OpenGL started to work, great. But XVideo stopped :( xvinfo reports
"no adapters present". Even when I wrote to XF86Config-4
Option "Overlay" "on"
Option "OpenGLOverlay" "off"

I see following in /var/log/XFree86.0.log:
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation

but there is no XVideo still. :(

OK, I tried xvidix. Now there was another bug: I saw random patterns
instead of video. Interesting thing, -vop pp worked, but there was no
use of it.
There is some info about limiting video memory in documentation
(strange, I didn't need this with first driver). But results were even
more strange: when I tried option "VideoRam 61440" in config, XFree86
crashed the system. The computer hung immediately on XFree86 start,
"hard way" (i.e.  kernel stopped working, only reset helped).  Then I
tried "VideoRam 32768". Now XFree86 started, but every time I tried
mplayer -vo vidix just after vidix initialization computer hung the same
way. Everything else worked file, these crashes were of course

So, I tried -vo gl. It didn't worked with libmpeg2, it just segfaulted,
so I had to set -vfm ffmpeg. The picture was fine, and cpu usage for
video output was but there were two
major bugs: OSD didn't work at all, and switching from fullscreen to
window crached mplayer with SIGABRT in vo_check_events (win->fs
switching worked). So, this gl output was unusable too.

Then I tried -vo gl2. It wrote that hardware gl is used, but everything
was damn slow (40% cpu usage on 320x240 file, >200% on 640x480) and
fs-win switching didn't work. I was able to start mplayer in fs or
window, but that's all.

All other drivers I tried didn't worked well too, -vo dga just failed to
load, it seems that DGA isn't supported by fglr200 driver. -vo vesa:dga
or -vo vesa:xvidix always caused kernel Oops :-/

I hadn't tried framebuffer, but I have no plans using it.

So, for now I'm stuck with unaccelerated sw-scaled x11/sdl:x11 output.
Or, I can drop out opengl and use other driver with xv output. All other
drivers aren't suitable, even xvidix/gl/gl2 in both cases. I really
don't want to live this as is! Can anybody help me?

PS I think I caught lot of mplayer bugs or misfeatures, but I don't
really want to report them all right now. I wish to set up something
better than I have now, and after that I'll report real bugs (if any)
one by one.



More information about the MPlayer-users mailing list