[MPlayer-users] RH8: Can't Use VESA, Even As Root

Dan8827 dan8827 at snet.net
Fri Feb 7 00:40:37 CET 2003

Hello all,

I've just switched from Redhat 7.0 to 8.0, and have run into a problem
using the VESA driver as root (as a means to output to TV), which worked
fine with RH7.  

Typically on RH7, I'd switch over to a text console, log in as root,
activate TV-Out with the "atitvout" program, then run mplayer with the
-vo vesa:vidix option.  This worked beautifully under Redhat 7, but on
Redhat 8, mplayer tells me that this requires root privileges, even
though I'm logged in as root.  With RH8, I can be in an X session as a
normal user, su to root, and successfully invoke xvidix from a command
line, but never VESA.  With drivers other than VESA, I'm not having any
problems with any particular format or codec.  (Well, except for that
pesky Animatrix file, but I've been reading the list, so I know why....)

The last few lines of the output from "mplayer -v -vo vesa:vidix
hack-sign-05.avi" is as follows:

Starting playback...
[ffmpeg] aspect_ratio: 0.000000
VDec: vo config request - 640 x 360 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO Config (640x360->640x360,flags=1,'MPlayer',0x32315659)
VO: [vesa] 640x360 => 640x360 Planar YV12  [fs]
VO: Description: VESA VBE 2.0 video output
VO: Author: Nick Kurshev <nickols_k at mail.ru>
VO: Comment: Requires ROOT privileges

(Although vesa:vidix is what I'd typically use, I have the same problem
with -vo vesa, -vo vesa:dga, or any other usage of VESA I've tried.)

I suspect the problem is not with MPlayer, but some sort of
driver/device/permissions problem elsewhere on my system.  Any thoughts
on where I can begin looking?  The RH8 install is on the same machine as
RH7, so doesn't seem like a hardware issue.  Also, I'd used rc3 on RH7,
so I don't think it's related to a specific version difference.  I've
still got RH7 installed as well, so I should be able easily compare
files/drivers between the two systems, or reboot to RH7 and examine the
mplayer output, if I can get some hints as to what to look for.

Some details on my current setup:

Pentium II 266 MHz CPU
ATI Rage Fury Pro 32 MB AGP card
Redhat 8.0, including XFree86 4.2.0, kernel 2.4.18
GATOS drivers
MPlayer rc3, installed from the following RPM's:

Any thoughts?  I've never run into a permission problem as root before;
it's an interesting little dilemma.  

Thanks for any help you can offer.

Increasing The Entropy Of The Universe Since 1972

More information about the MPlayer-users mailing list