[MPlayer-users] [BUG] DVD chapter seeking problem

Timo Jyrinki timo.jyrinki at hut.fi
Wed Aug 13 14:30:35 CEST 2003


I'm having a problem with MPlayer (cvs) and "-chapter" option. I've 
Babylon 5 Season Two -DVD-package (PAL, 6 DVDs), and seeing the last 
episode of four on any of the 6 DVDs seems problematic. I'm taking an 
example of this disc 2 I'm using now:

1. mplayer dvd://1 -chapter 13 correctly starts at the third episode - 
there are 24 chapters, so 1=1st ep, 7=2nd ep, 13=3rd ep and 19=4rd ep.
2. mplayer dvd://1 -chapter 19 (or anything above) starts at the same 
location as -chapter 13, and trying to seek forward results in black screen
3. mplayer dvd://1 -chapter 18 starts correctly near the beginning of 
the 3rd episode, but trying to seek past the end of episode texts 
results in mplayer quitting when the 4th episode starts
4. doing as before, -chapter 18, but letting the end texts roll, gives 
me finally the 4th episode to watch, though I shall not try to seek or 
I've a long time to wait to catch the same position again :(

Running MPlayer with '-v' doesn't show up any differences besides that 
with -chapter 19 there's a line "TRIED UP TO POSITION 3713847625, FOUND 
0, packet_size= 71", where with earlier chapters there is a line with 
"FOUND 1" instead.

I don't know how could I give something with which to reproduce this, 
uploading 7GB to mplayer's ftp is probably not an option :) MPlayer is 
compiled with the defaults, ie. libmpdvdkit2.

Any ideas, or anyone able to reproduce this? I haven't tried 
libcss/libdvdread yet because they'd be no use for me because I'm 
watching DVDs with Movix's bundled MPlayer anyway. I'm using Movix 
because TV-out doesn't work in my 'too-recent' distribution I'm normally 
using, -vo vesa segfaults. This is the glibc&mplayer&vesa -problem there 
have been posts about.


More information about the MPlayer-users mailing list