[MPlayer-users] trouble playing Sorenson Video 3 (SVQ3) files

Magnus Damm damm at opensource.se
Fri Aug 8 12:19:23 CEST 2003

Hi there,

I'm not sure, but I think SVQ3 support was added to ffmpeg
after the 0.90 release. And mplayer includes it's own version
of ffmpeg so the other one installed on you system does not
matter to mplayer. And generally, the 0.90 release is really
outdated compared to CVS main. Too bad no-one is doing releases

So, use CVS to get the latest version of mplayer. And you
will also need to use CVS to get libavcodec from ffmpeg.

The homepage for mplayer (under Download) tells you how 
to  use CVS to get mplayer. And the README file in the 
distribution tells you all about libavcodec and CVS.

I downloaded a few seconds of the movie and the CVS version 
of mplayer + libavcodec plays the movie ok!

Good luck!

/ magnus

On Thu, 7 Aug 2003 18:20:55 -0500 (CDT)
William R Sherman <wsherman at ncsa.uiuc.edu> wrote:

> [Automatic answer: RTFM (read DOCS, FAQ), also read DOCS/bugreports.html]
> Hello Mplayers,
> I'm having trouble playing a downloaded video clip using mplayer.
> I can hear the audio, but the video will not play.  I'm using a
> recent version of mplayer (0.90rc4-2.96 -- from an AMD rpm I
> found on the web), and I have a recent version of ffmpeg that
> is capable of playing Sorenson-3 videos.  I know this works
> because xine plays the file fine using the ffmpeg codecs.
> The reported error is that it can't find some Windows DLL file:
> 	/usr/local/lib/win32/qtmlClient.dll
> I've tried using the "-vc" option to avoid the "qtvideo" codecs,
> but that hasn't helped.  I hope someone can explain what I'm
> doing wrong in how I attempt to use the ffmpeg codecs instead
> of the qtvideo ones.  (I'm sure mplayer supporters don't want
> xine playing videos they can't play!)  Here is what I tried (and
> failed):
> 	% mplayer ThePassion.mov
> 	% mplayer -vc qtsvq3 ThePassion.mov
> 	% mplayer -vc ffmpeg ThePassion.mov
> 	% mplayer -vc ffsvq3 ThePassion.mov
> 	% mplayer -vc ffmpeg12 ThePassion.mov
> 	% mplayer -vc -qtvideo, ThePassion.mov
> Often when I try to force the codec, I get the message:
> 	"Cannot find codec matching selected -vo and video format 0x33515653."
> Also, the ffplay program handles the video fine, but adds noise
> to the audio, and loses sync between audio and video.
> Here is where you can download the offending file -- it's about
> 15Meg:
> 	http://www.movie-list.net/ThePassion.mov
> I've run across other files with unplayable video (still SQV3),
> and also unplayable audio (QDM2), which also seems to want the
> qtmlClient.dll.  Preferably of course, I'd rather not have to
> depend on some windows DLL -- especially since I know other
> plays work fine without it.
> 	Thanks in advance,
> 	Bill
> --
> Bill Sherman
> VR Impresario & co-author "Understanding Virtual Reality"
> NCSA Virtual Environments Group
> wsherman at ncsa.uiuc.edu
> _______________________________________________
> RTFM!!!  http://www.MPlayerHQ.hu/DOCS
> Search:  http://www.MPlayerHQ.hu/cgi-bin/htsearch
> http://mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list