[MPlayer-users] TV-in on the Radeon 7500 QW

Brian T Neltner neltnerb at MIT.EDU
Sat Apr 26 20:04:42 CEST 2003

Okay, I looked through all the archives and couldn't find anyone that is
having the problem I am, I checked all the documentation, and have played
with this one for a few hours.

I'm using Debian sid with kernel 2.4.21rc1, afterstep as a window manager.

I have my Radeon connected to a VCR via the composite plug, and am trying
to capture video sent from the VCR to the computer.

I am running the current CVS version of the GATOS km, drm, and
XFree86-4.2.0-16 ATI drivers.  I am running XFree86-2.4.1-6 from a debian

I can view video fine with avview or xawtv, although neither is capable of
recording it... avview doesn't compile when I include ffmpeg support and
when I try capture with xawtv from the debian package, it claims grabbing
is not supported.  But regardless, the radeon composite input is
definately getting a signal.

I'm not completely sure what options I should be using (at least as far as
which input is appropriate-- the man file doesn't list what the
correlation is), but I've tried all the available input possibilities.

Here's the output for one attempt.  I've tried with -tv on:... instead of
the tv://.  I've also tried all the input=<foo> options and tried without

neltner:/#mplayer -tv driver=v4l:input=1:channel=4 tv://

Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MPlayer 0.90rc5-3.2.3 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Athlon TB Thunderbird (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: can't open
'/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf : No such file or
Can't open input config file /etc/mplayer/input.conf : No such file or
Falling back on default (hardcoded) input config

Playing TV
TV detected! ;-)
Selected driver: v4l
 name: Video 4 Linux input
 author: Alex Beregszaszi <alex at naxine.org>
 comment: under development
Selected device: Km
 Capabilites: capture
 Device type: 1
 Supported sizes: 640x239 => 640x239
 Inputs: 1
ioctl get channel failed: Invalid argument
ioctl get mbuf failed: Invalid argument
Falling back on trying to parse playlist TV...
============ Sorry, this file format is not recognized/supported
=== If this file is an AVI, ASF or MPEG stream, please contact the author!

Exiting... (End of file)

In addition, dmesg tells me the following:


Purging transfer queue
radeon_get_window_parameters: width=640 height=239
Capture buf size=305920
Starting GUIDMA queue
radeon_get_window_parameters: width=640 height=239
Stopping GUIDMA queue
km: closed stream, 0 buffers captured
Purging transfer queue

Does anyone know how to make mplayer and the GATOS drivers happy?  What
is ioctl get channel?  The errors seem to be identical regardless of what
arguments I give mplayer.

Thanks for any advice,

More information about the MPlayer-users mailing list