[MPlayer-users] Mplayer 0.90 Playback gives snowy bars in window

Jon Earle je_mplayer at kronos.honk.org
Tue Apr 15 16:52:55 CEST 2003

Hi folks,

New to mplayer and while I've got it running, I've encountered a small

First, my system is an Intel P4 1.4GHz, 384MB ram, 32MB nvidia Riva TNT 64
(AGP), Debian 3.0r0 (updated to latest stable), kernel 2.4.18 compiled for
my system.

At first, I used the 'nv' driver that came with X.  Mplayer worked, but
video lagged behind the audio and I got the "your system is too slow.. "
messages.  Then, I fooled around with the latest nvidia drivers and
eventually got X to run.[1]  Now when I run mplayer, the video and audio
are in sync, but, the playback of a quicktime mov (the latest matrix
trailer) now includes a bunch of semi-transparent, snowy bars in various
shades of grey on the right-hand side of the screen (occupying about 1/5
of the playback screen).

No more "system too slow messages" but I do notice the following when I
playback the clip:

Opening video decoder: [qtvideo] Quicktime Video decoder
External func COMCTL32.dll:17
External func COMCTL32.dll:16
QuickTime6 DLLs found
QuickTime.qts patched!!! old entry=0x6693b330
theQuickTimeDispatcher catched -> 0x6693b330
Win32 Warning: Accessed uninitialized Critical Section (0x66bc4210)!
WARNING! Invalid Ptr handle!
Win32 Warning: Accessed uninitialized Critical Section (0x66bc41f8)!

Don't know if that means anything, but it appears to be the only error
(aside from a complaint that /dev/rtc is inaccessbible ['cause it's not
compiled in my kernel]).  When I built the kernel, I disabled the AGP
support since none of the drivers listed fit my card and the bootup
message said it was disabling (or something to that effect) agpart.  I
presume since I now force the nvidia card to use its own AGP (at 2x)
rather than agpart, then AGP is working for this card.

Not sure what else to do.  I've recompiled since I got the new driver
working and the same result occurs.

Anyone else seen this?  Better yet, anyone have an idea how to fix it?


[1] Initially I had to diable AGP in the nvidia driver, then I recompiled
the driver source to force AGP 2x - haven't tried 4x.  Without the AGP
changes to the XF86Config-4 file, X would freeze up when loaded (I could
access the system over the network however).

More information about the MPlayer-users mailing list